Installing and Running HXEN

For those of you who have not tried the new HXEN – Hosted Xen project, I want to go through some of the issues I had installing and running the hypervisor on my Windows XP Tablet machine.

STEPS:

*** Make sure that your machine has Virtualization hardware enabled (E.g. Intel VT-d) ***
*** Make sure that your user profile has administrative rights on the machine you are running ***

1) Download the HXEN application from http://www.xen.org/download/HostedXen/snapshots/kxen-preview-090323-windows.zip

2) Download and install OpenVPN-2.0.9 from http://openvpn.net/release/openvpn-2.0.9-install.exe. Only the TAP-Win32 Virtual Ethernet Adapter needs to be installed for this application.

3) Open Networking Window and change the name of the newly appearing Networking Connection to “kxen-tap”. NOTE – I changed the “Local Area Connection-3″ icon to kxen-tap.

4) Internet Connection Sharing – I run my Wireless Network Connection as the active Internet source so I opened up the properties of that icon, selected Advanced – and checked “Allow other network users to connect through this computer’s Internet connect” which also forced me to select kxen-tap in the pull down  menu.

5) In the directory where you stored the downloaded HXEN files you will see an images folder and may need to create an isos folder as well. The Startvm.bat file will need to be updated to give the application the proper DISKIMAGE and CDIMAGE.

* If you create a new folder please select properties and unmark the ReadOnly setting
* The Readme has instructions on creating an empty disk image createimg.exe images\testdisk.img 8 1024 1024 1024 for use with a valid CD iso image .
* I obtained a valid ISO image of Vista and placed it in my iso folder

6) Double click StartVM.bat and the application will open a new window where the VM operating system will load.

ISSUES:

** I have seen problems stopping the ioemu.exe process from stopping using the Windows Task Manager
** I tried to run a Jailtime.org Fedora9 image (.img) file with no Disk Image file (.iso) and the system cannot load that image. Still working on this issue to see if there is a solution
** I am able to bring up Vista on my VM but during installation the OS gives everyones favorite blue screen of death. I am still looking into this issue

TOOLS

*** I used the debugview (http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx) tool for kernal trace.  You need to enable the option to display kernel messages, then send its output to a file for later checking.
*** The HXEN tool creates a stderr and stdout file in the same directory that the .bat file is run from. These tools can give you relevant information on what is happening.

Looking to see comments from others who have tried the inital HXEN release for more feedback.