GPLPV drivers update

From time to time, I plan to post items from the xen-devel mailing list that I think may be of interest to a wider audience. The complete threaded discussion in xen-devel to this email is found at

From James Harper:

I have just uploaded a new testing version of GPL PV drivers for Windows. Have a look for at (the -dontuse bit is to scare people away who haven’t read this email :)

As usual, please test thoroughly on a test DomU and make sure you have a backup before installing on a non-test system. In particular, I’m only testing with Xen 3.4.1 these days so anything older isn’t tested although it should work.

There was a problem with the signing of the drivers that would prevent them working properly under Vista/2008 x64 even with testsigning enabled. This should resolve that.

The installation procedure for Vista/2008 x64 is as follows:

. Run ‘bcdedit /set testsigning on’

. Reboot

. Install the drivers. Accept any warnings and tick ‘always trust…’

when prompted.

. Make sure you now have PV network and SCSI adapters present . Reboot

If something doesn’t work, you should be able to boot to safe mode unless you forgot to run ‘bcdedit /set testsigning on’ in which case you will probably have an unbootable system… for some reason the vista F8 boot menu doesn’t allow you to turn on testsigning and safe mode at the same time. Ideally the installer would be able to detect that we are using a test certificate and instruct you to turn on testsigning first but I don’t yet know how to do that. I’ll see if I can at least put in a loud warning at installation time…